Quali sono le librerie necessarie per usare Rails?

Utente HTML.it
chiede

Quali sono le librerie necessarie per usare Rails?

Redazione HTML.it
risponde

Rails è distribuito come GEM ed è composto da 6 librerie differenti ma complementari:

  1. Rails (Railties)
  2. ActiveSupport
  3. ActiveRecord
  4. ActionPack
  5. ActionMailer
  6. ActiveResource

L’installazione di queste librerie avviene automaticamente in fase di installazione della GEM Rails. A seconda del database utilizzato potrebbe essere necessaria l’installazione della GEM contenente i driver richiesti, come ad esempio nel caso in cui si scelga SQLite.