Nessun risultato. Prova con un altro termine.
Guide
Notizie
Software
Tutorial

La scelta dell'adattatore

Non tutti gli adattatori funzionano bene con aircrack-ng; ecco come sceglierli
Non tutti gli adattatori funzionano bene con aircrack-ng; ecco come sceglierli
Link copiato negli appunti

Non tutti gli adattatori funzionano bene con aircrack-ng; ecco come sceglierli

Al fine di utilizzare la suite aircrack-ng, è necessario possedere un adattatore wireless da essa supportato che sia nel contempo in grado di "iniettare" e funzionare in modalità monitor; il sito Web del programma indica e consiglia di acquistare una scheda di rete basata sul chipset RT73.

Per l'intera guida ho usato un adattatore wireless USB D-LINK DWL-G122 rev.C1, comunemente presente sul mercato, che fa appunto uso del chip appena menzionato.

Il sistema operativo usato è Linux (Debian) né esistono tuttora strumenti di cracking wireless effettivamente utilizzabili su sistemi della famiglia Microsoft Windows, per una varietà di motivazioni.

Altri adattatori

Ogni moderno notebook è dotato di adattatore di rete wireless interno: per verificare se esso sia compatibile con aircrack-ng è necessario conoscerne il chipset usato. A tal fine, il consueto comando lspci, che dà informazioni sui device PCI interni, seguito da una ricerca su Internet o sul sito Web detto, ci potrebbe dare gradite sorprese. Se così fosse, rimando al sito per i driver da utilizzare. Per eventuali adattatori esterni USB usare invece il comando lsusb.

Torniamo comunque all'adattatore D-LINK detto. Per prima cosa, è necessario scaricare i driver opportunamente "patchati", consigliati da aircrack-ng, dal sito di Pedro Larbig e scompattarli ove desiderato, ad esempio nella directory /tmp. Questi driver posseggono anche il supporto per il fragmentation attack (che tuttavia non tratteremo in questa guida base).

Nelle lezioni successive vedremo come compilare e installare i driver scaricati. Da premettere che la versione dei driver usati per questa guida disponibili a marzo 2009 è la 3.0.2.


Ti consigliamo anche