Le classi e gli script pensati per PHP 4 continueranno a funzionare?

Utente HTML.it
chiede

Le classi e gli script pensati per PHP 4 continueranno a funzionare?

Redazione HTML.it
risponde

In teoria sì, gli sviluppatori hanno lavorato molto per garantire la retrocompatibilità e, specialmente se gli script sono stati realizzati a regola d’arte, non ci dovrebbero essere problemi. Anche nel caso di differenze incolmabili (come ad esempio l’assegnazione degli oggetti come copia anzichè riferimento) abilitando in php.ini la direttiva specifica “zend.ze1_compatibility_mode” funzionerà tutto come prima.