Gallery: una galleria di foto in PHP

30 ottobre 2008

La condivisione delle immagini è un fenomeno diffuso su internet. Inserire immagini sul proprio blog o forum è diventata una cosa molto semplice, con pochi clic e senza operazioni complicate si può ora mai fare tutto.

Se volessimo usare applicazioni esterne potremmo fare un salto usare Flickr o PicasaWeb. Se invece volessimo pubblicare sul nostro sito tutte le nostre immagini, per condividerle con amici e parenti oppure per creare una galleria personale, ci occorrerebbe un’apposita applicazione web.

Ecco che entra in campo Gallery, uno dei più noti e utilizzati software per la creazione e gestione di gallerie di immagini.

Il logo di Gallery

Attualmente Gallery è uno dei migliori software basati sul Web per gestire in modo avanzato e professionale la propria galleria di immagini. Supporta molte funzioni ed inoltre, per chi volesse, può essere integrato con oltre 25 versioni di blog, forum, portali e CMS. Gallery è stato scritto pensando principalmente all’utilizzo da parte di tutti i tipi di utenti, principianti compresi (ma non per questo manca di funzioni per gli utenti più avanzati) e la sua installazione è semplice, guidata e si completa con pochi clic.

Con Gallery si ha la possibilità personalizzare il tema, si può sceglierne uno già fatto direttamente dal pannello di amministrazioni oppure crearne uno secondo i propri gusti. Non lasciatevi spaventare dal sito completamente in lingua inglese, il software supporta oltre 20 linguaggi di localizzazione tra cui l’italiano.

Prima di procedere, vediamo i requisiti minimi richiesti per poter procedere con l’installazione:

  • WebServer: Apache 1.x o 2.x (raccomandato dagli sviluppatori di Gallery), IIS ultima versione;
  • Sottosistema PHP: Gallery 2 richiede PHP 5.2 o superiori per funzionare al massimo delle prestazioni, funziona anche con le altre versioni di PHP ma non al massimo delle sue potenzialità. Con PHP 5.0.5 Gallery 2 ha dei problemi dovuti ad un bug in questa versione del PHP;
  • Database: MySQL 3.x or 4.x, 5.x, PostgreSQL 7.x, 8.x, Oracle 9i or 10g, IBM DB2 8.2, Microsoft SQL Server.

Se il nostro server sul quale è ospitato il nostro sito soddisfa tutti questi criteri allora possiamo procedere con il download e l’installazione del software, altrimenti dobbiamo obbligatoriamente sistemare i parametri richiesti pena il malfunzionamento dello script.

Se vuoi aggiornamenti su Gallery: una galleria di foto in PHP inserisci la tua e-mail nel box qui sotto:
 
X
Se vuoi aggiornamenti su Gallery: una galleria di foto in PHP

inserisci la tua e-mail nel box qui sotto:

Ho letto e acconsento l'informativa sulla privacy

Acconsento al trattamento dei dati per attività di marketing